zerosleeps

Since 2010

Astonishing indeed

Thursday 14 January 2021

Yep to this entire thread on Ruby on Rails Discussions. Rails is a shit-show at the moment, and this thread shows why. You need (deep breath): Ruby, probably a Ruby version manager, Rubygems, Bundler, Rails itself, Node.js, the Webpacker gem, the Webpacker Node.js package, Webpack itself, Yarn (because Webpacker doesn’t use npm), Python (WTF), and some sort of database layer.

What versions of all of the above work together? Nobody knows. And the first time Bundler is run a bunch of Rails dependencies are compiled - in my experience, in a brand new environment, at least one of those always fails (usually sass).

And even if you get all of that working together, the “Getting Started with Rails” guide is woefully out-of-date. Last time I looked, the Rails Guides didn’t mention Webpack at all. Anywhere.

Yet front-and-centre on the Rails home page it states:

Learning to build a modern web application is daunting. Ruby on Rails makes it much easier and more fun.

Not any more it doesn’t.